Minecraft(我的世界)中文论坛

 找回密码
 注册(register)
查看: 49447|回复: 312

[生存] [1.13-1.13.2][PaperSpigot]HTL9257的1.13.X基本插件整合服务端[2.17更新]

  [复制链接]
HTL9257 当前离线
帖子
主题
精华
贡献
最后登录
1970-1-1
爱心
积分
16449
钻石
性别
保密
注册时间
2016-2-28
查看详细资料
发表于 2018-7-23 01:39:16 | 显示全部楼层 |阅读模式
"服务端整合包"
中文名称: HTL9257的1.13.X纯净整合包
服务端类型: Spigot 
来源: 原创
最后更新: 2019-01-17
适用版本: 预览版(下面注明) 1.13 
语言支持: 简体中文 English 
包含内容: 基本插件 纯净核心
下载地址: http://www.见贴内.com
声明:以任何方式散布修改的客户端jar文件的行为本身违反《Mojang最终用户许可协议》,而且客户端Mod整合包本身具有潜在的安全隐患与版权问题。Minecraft中文论坛仅提供本专区作为用户交流使用,对本版的一切内容随时保留应Mojang AB或Mod作者要求采取删帖等行为的权力。MCBBS对于整合包本身对您的计算机造成的一切后果概不负责。

您尚未登录,立即登录享受更好的浏览体验!

您需要 登录 才可以下载或查看,没有帐号?注册(register)

x
本帖最后由 HTL9257 于 2019-7-24 14:05 编辑

HTL9257的水域纯净整合包
简介
因近日spigot发布了正式版的服务端 故出此整合包 方便各位开服 联机
这是一个精简的服务端 仅仅含有服务端核心 bat 以及插件 剩下的请按需自行配置


包含的插件
插件介绍
管理/安全类
-Essentials
-Yum
-Authme
-EntityLWC
-梨子防火墙
-WorldEdit
-LaggRemover
-Multiverse
-LuckPerms(如果你是熟手建议使用luckperms)
-Residence
-CoreProtect
-WorldGuard

经济类
-Vault
-iConomy (如果你不需要数据库储存可以删掉它)
-QuickShop
-playmoney
信息提示
-HolographicDisplays
-ChestCommands
-SkinsRestorer
-MiaoBoard
-MiaoChat
-ColorMOTD
娱乐/添加功能
-AdvancedAchievements
-RandomPlacer
-Portable_Warehouse
-CrazyCrates
-RifleChairs
-AkkariinSign
-Citizens2
-CitizensCMD
前置
-ProtocolLib
-PlaceholderAPI
插件截图
QQ截图20180723012100.jpg
开服截图
QQ截图20180723012319.jpg


插件兼容性
部分测试过的插件兼容性
spigot官方提供的插件兼容性列表

                               
登录/注册后可看大图
经过本人测试的列表(最后更新7.23)
此份列表可能会随着插件更新而失效仅供1.13初期参考
以下列表已失效 (10.29 现在大多插件已经陆续支持1.13)
不兼容/不运行
AAC反作弊
Residence 蹦服(4.8以下) 请使用最新版  最新版能在1.13运行
FeatherBoard (计分板)
NeverLag1.3.0 (知名的清理/bug修复/防止卡服插件)
ItemExpansionEnchantments 物品扩展包
CrazyCrates 抽.奖
PrefixManager 称号
CoreProtect_2.14.2 查询插件 (加载到一半卡死 不生成配置文件)
PlayerBox2.1 输入指令报错
GlobalShop 输入命令无反应
ProtectPlugin 运行 但是输入指令无效
BanItem_with_NBT 正常运行 但是输入ban指令提示出现内部错误  是否可以配置文件添加暂不清楚
完全兼容
authme 但是不支持中文
SkinsRestorer (正版皮肤显示)
Miaochat 用不了PlaceholderAPI
ColorMOTD
ProtocolLib
Yum
AdvancedAchievements (自定义成就)
ChestCommands (指令菜单)
iConomy 经济
BossShop 依旧不支持部分变量
QuestWorld 任务RandomPlacer 随机传送
RPGItems-Reloaded (RPG插件)
DeluxeTags(称号)
EntityLWC (锁箱)
MMOItems (自定义物品)
WeatherTimeLockLaggRemover(清理)
ServerMarket (经验市场)
QuickShop (需要下载喵呜版的)
MiaoBoard 计分板
梨子防火墙
PlaceholderAPI-2.9.1
WowSuchCleaner
Crazy Auctions 全球市场
Marriage-Reloaded 结婚
Guilds 公会
EnderContainers 末影箱仓库
CoreProtect v2.15.0 请使用最新版本 (2.14用不了 )
lockettepro 牌子锁
playerpoints
titlemanager 请使用最新版
vipzero
TAB
Residence4.8.0.0Experimental(请使用最新版)
Citizens (NPC) 请使用最新版
HolographicDisplays (全息图) 请使用最新版
Dynmap 请下载最新版
能够运行但是报错
FastAsyncWorldEdit
已知问题/更新
不建议更新1.13.1 最好待1.13.X稳定版更新后再做更新 但是我还是准备了1.13.1的服务端
1.13在BC群组内运行时  若登入服务器是1.12.2 再跨服入1.13 会造成玩家无法进入船 矿车的情况 (马似乎不会受影响)测试环境跨服端为waterfall
使用最新构建的waterfall已无此问题 (7.25)
7.29 res原贴已经更新1.13 本帖随之更新并加入 将服务端更新为最新构建
8.2 将ESS更新到spigot的版本  如果有问题请换回7.29的
8.29 权限插件更新为luckperms 如果不会用请使用网盘内的GM替换
原GM插件升级导入luckperms指令 输入 /lp migration GroupManager true
基本权限配置文件已经在网盘内放出  使用方式 将luckperms配置文件config中storage-method: yaml
将下载的文件复制进yaml-storage文件夹 替换即可
基本权限/权限公示↓
groups.zip (6.25 KB, 下载次数: 512)
警告1.13.1暂不兼容Res 请自行下载最新版本(10.29)
提取码cq9g
7.24更新 更新一个paperspigot核心的版本的整合包(插件一样)  可以选用  服务端核心更新地址(下载替换核心 修改启动Bat文件名即可 )
paperci.emc.gs


评分

参与人数 16人气 +20 金粒 +140 收起 理由
MC师生 + 1 MCBBS有你更精彩~
hehe768 + 1 + 15 灰太狼nb
mimimis + 3 MCBBS有你更精彩~
bnn512644 + 2 + 10 神乎其技,不服不行!
583736449 + 2 + 35 高亮 & 加粗
tmfish + 10 MCBBS有你更精彩~
堕落男 + 1 + 10 制作不易,感谢
yuannnn + 1 + 10 Ssssssssssssssssssss
bwz + 15 感谢大佬
1977719110 + 10 Ssssssssssssssssssss
秋韵 + 2 辛苦了
Cod + 2 MCBBS有你更精彩~
luosang + 1 + 15 持续跟帖 希望及时更新
Green_sea_233 + 1 MCBBS有你更精彩~
blackangel + 2 + 10 大佬666啊
隔壁柴先生 + 1 果然还是要靠大佬,望长久更新~.

查看全部评分

HTL9257 当前离线
帖子
主题
精华
贡献
最后登录
1970-1-1
爱心
积分
16449
钻石
性别
保密
注册时间
2016-2-28
查看详细资料
 楼主| 发表于 2019-2-17 18:34:27 | 显示全部楼层
本帖最后由 HTL9257 于 2019-2-17 18:36 编辑

2.17更新

现在开启服务器需要同意EULA了 不再默认为true

已经预先下载好了依赖文件 防止网络连接问题导致长时间下载

更新paper到525

更新插件

CrazyCrates到1.85

Residence到4.8.4.4

PlaceholderAPI到2.9.2

LuckPerms到4.3.73

SkinsRestorer到1.13.6

Advanced Achievements到5.11.1

删除bossShop 因为它长期没更新1.13 且报错和反应迟钝

若有需要请使用付费版(BossShop pro)

添加插件

AkkariinSign 轻量的签到插件  支持配置物品/金币

Citizens2 NPC插件(免费发布版)

CitizensCMD NPC执行命令




回复

使用道具 举报

Pangxie_ 当前离线
帖子
主题
精华
贡献
最后登录
1970-1-1
爱心
积分
3094
钻石
性别
保密
注册时间
2017-4-6
查看详细资料
发表于 2018-7-23 02:36:23 | 显示全部楼层
有办法能支持bc跨服吗?BungeeCord,Travertine,Waterfall核心都试了不行,主服核心spigot1.12.2,ViaVersion 1.4.1两个端都装了还是跨不了1.13
回复

使用道具 举报

HTL9257 当前离线
帖子
主题
精华
贡献
最后登录
1970-1-1
爱心
积分
16449
钻石
性别
保密
注册时间
2016-2-28
查看详细资料
 楼主| 发表于 2018-7-23 02:40:14 | 显示全部楼层
Pangxie_ 发表于 2018-7-23 02:36
有办法能支持bc跨服吗?BungeeCord,Travertine,Waterfall核心都试了不行,主服核心spigot1.12.2,ViaVersion ...

有 我现在在用  用的waterfall  最新构建  登录服1.12.2paperspigot 需要装ViaVersion-1.4.1  BC端无需安装
与BungeeAuthMeBridge 不兼容 会造成1.13登录后无法输入指令
回复

使用道具 举报

Pangxie_ 当前离线
帖子
主题
精华
贡献
最后登录
1970-1-1
爱心
积分
3094
钻石
性别
保密
注册时间
2017-4-6
查看详细资料
发表于 2018-7-23 02:45:20 | 显示全部楼层
本帖最后由 Pangxie_ 于 2018-7-23 02:54 编辑
HTL9257 发表于 2018-7-23 02:40
有 我现在在用  用的waterfall  最新构建  登录服1.12.2paperspigot 需要装ViaVersion-1.4.1  BC端无需安 ...

bc端不安装你确定1.13客户端能进入1.12.2的主服吗?authme可以正常使用?waterfall是自带兼容1.7所有核心的吗?我bc装了ViaVersion 1.4.1 ViaBackwards 2.3.1 ViaRewind 1.3.10这三个,主服也是装的这三个,提示就这样了

                               
登录/注册后可看大图
,那个构建版的waterfall我也试了,不过我没试过bc端不装跨版本插件...有办法能让bc兼容1.7-1.13么(大佬有qq吗,我看你的签名挺厉害的emmmm)
回复

使用道具 举报

blackangel 当前离线
帖子
主题
精华
贡献
最后登录
1970-1-1
爱心
积分
3365
钻石
性别
保密
注册时间
2014-6-14
查看详细资料
发表于 2018-7-23 11:53:54 | 显示全部楼层
大佬我能不能把你的帖子挂到我的Ess帖子下面?
(虽然说我已经挂出来了233)
回复

使用道具 举报

youngklps 当前离线
帖子
主题
精华
贡献
最后登录
1970-1-1
爱心
积分
2799
钻石
性别
保密
注册时间
2014-4-26
查看详细资料
发表于 2018-7-23 19:56:29 | 显示全部楼层
本帖最后由 youngklps 于 2018-7-23 21:02 编辑

给出的protocolib 版本不正确,疯狂报错
http://ci.dmulloy2.net/job/ProtocolLib/lastStableBuild/
回复

使用道具 举报

qq2913467007 当前离线
帖子
主题
精华
贡献
最后登录
1970-1-1
爱心
积分
1703
钻石
性别
保密
注册时间
2015-4-1
查看详细资料
发表于 2018-7-24 08:54:29 | 显示全部楼层
ess死亡 直接卡崩服务器
回复

使用道具 举报

HTL9257 当前离线
帖子
主题
精华
贡献
最后登录
1970-1-1
爱心
积分
16449
钻石
性别
保密
注册时间
2016-2-28
查看详细资料
 楼主| 发表于 2018-7-24 08:57:05 | 显示全部楼层
qq2913467007 发表于 2018-7-24 08:54
ess死亡 直接卡崩服务器

在我这没有这种情况  已知的问题在pre7的情况下 ess设置spawn 输入spawn命令会卡蹦服务器  不知道正式版是否修正
回复

使用道具 举报

HTL9257 当前离线
帖子
主题
精华
贡献
最后登录
1970-1-1
爱心
积分
16449
钻石
性别
保密
注册时间
2016-2-28
查看详细资料
 楼主| 发表于 2018-7-24 09:23:45 | 显示全部楼层
youngklps 发表于 2018-7-23 19:56
给出的protocolib 版本不正确,疯狂报错
http://ci.dmulloy2.net/job/ProtocolLib/lastStableBuil ...

已更新
回复

使用道具 举报

qq2913467007 当前离线
帖子
主题
精华
贡献
最后登录
1970-1-1
爱心
积分
1703
钻石
性别
保密
注册时间
2015-4-1
查看详细资料
发表于 2018-7-24 11:58:46 | 显示全部楼层
HTL9257 发表于 2018-7-24 08:57
在我这没有这种情况  已知的问题在pre7的情况下 ess设置spawn 输入spawn命令会卡蹦服务器  不知道正式版 ...

还有这种情况,ess会随时崩溃。
回复

使用道具 举报

小vie 当前离线
帖子
主题
精华
贡献
最后登录
1970-1-1
爱心
积分
447
钻石
性别
保密
注册时间
2017-6-2
查看详细资料
发表于 2018-7-24 22:09:10 | 显示全部楼层
QS商店玩家卖出东西金钱无法到账
回复

使用道具 举报

HTL9257 当前离线
帖子
主题
精华
贡献
最后登录
1970-1-1
爱心
积分
16449
钻石
性别
保密
注册时间
2016-2-28
查看详细资料
 楼主| 发表于 2018-7-24 23:36:30 | 显示全部楼层
小vie 发表于 2018-7-24 22:09
QS商店玩家卖出东西金钱无法到账

我只负责测试兼容性  不能保证没有BUG 据其他人报告还有权限组添加权限无效的问题  具体插件bug请给该插件作者反应
回复

使用道具 举报

晋文公 当前离线
帖子
主题
精华
贡献
最后登录
1970-1-1
爱心
积分
259
钻石
性别
保密
注册时间
2013-4-6
查看详细资料
发表于 2018-7-25 00:29:45 | 显示全部楼层
领地插件不是用不了,是没法圈地,其实也不会蹦服,设置什么的都能调出来,游戏里面用蜘蛛线来查找领地的功能也可以。不知道为什么就是圈不了地。PS: WorldEdit插件我试了试,服务端可以读取但是用不了。
回复

使用道具 举报

HTL9257 当前离线
帖子
主题
精华
贡献
最后登录
1970-1-1
爱心
积分
16449
钻石
性别
保密
注册时间
2016-2-28
查看详细资料
 楼主| 发表于 2018-7-25 00:41:22 | 显示全部楼层
晋文公 发表于 2018-7-25 00:29
领地插件不是用不了,是没法圈地,其实也不会蹦服,设置什么的都能调出来,游戏里面用蜘蛛线来查找领地的功 ...

至少在我使用的那一个构建版本 领地插件装了服务器是开不起来的 WE用spigot原帖帖子里面github里面下载的那一个版本 是可以用的
回复

使用道具 举报

jumx0202 当前离线
帖子
主题
精华
贡献
最后登录
1970-1-1
爱心
积分
61
钻石
性别
保密
注册时间
2017-4-30
查看详细资料
发表于 2018-7-25 12:51:58 | 显示全部楼层
666666666666
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册(register)

本版积分规则

Archiver|小黑屋|Mcbbs.net ( 京ICP备15023768号-1 ) | 京公网安备 11010502037624号 | 手机版

GMT+8, 2019-8-26 06:02 , Processed in 0.062853 second(s), Total 27, Slave 26 queries , Gzip On, MemCached On.

"Minecraft"以及"我的世界"为Mojang Synergies AB的商标 本站与Mojang以及微软公司没有从属关系

© 2010-2019 我的世界中文论坛 版权所有 本站原创图文内容版权属于原创作者,未经许可不得转载

快速回复 返回顶部 返回列表