Minecraft(我的世界)中文论坛

 找回密码
 注册(register)

!header_login!

只需一步,立刻登录

查看: 473|回复: 5

[Mod安装] 正版启动器在不同游戏版本安装mod

[复制链接]
雪漫天 当前离线
积分
180
帖子
主题
精华
贡献
爱心
钻石
人气
下界之星
最后登录
1970-1-1
注册时间
2014-12-14
查看详细资料
发表于 2021-8-23 00:13:22 | 显示全部楼层 |阅读模式
100金粒
现况:在官方启动器下载了1.17.1并且成功安装fabric以及其他mod  (Java版本)
目的:在官方启动器下载1.16.5并且安装fabric环境下的其它mod
出现状况:1.16.5版本fabric显示安装成功后无法正常运行游戏。游戏路径尝试过默认路径(与1.17.1同一目录)和选择新位置,都无法打开1.16.5
求解决方法或建议
QQ截图20210823000908.png
QQ截图20210823000920.png

最佳答案

查看完整内容

1.16.5没法用java16 而1.17需要java16 推荐用PCL2/HMCL启动器 指定不同的java目录即可
Flowers_花花 当前离线
积分
11659
帖子
主题
精华
贡献
爱心
钻石
人气
下界之星
最后登录
1970-1-1
注册时间
2017-7-10
查看详细资料
发表于 2021-8-23 00:13:23 | 显示全部楼层
1.16.5没法用java16
而1.17需要java16  推荐用PCL2/HMCL启动器 指定不同的java目录即可
回复

使用道具 举报

白门 当前离线
积分
2251
帖子
主题
精华
贡献
爱心
钻石
人气
下界之星
最后登录
1970-1-1
注册时间
2021-1-25
查看详细资料
发表于 2021-8-23 06:49:16 来自手机 | 显示全部楼层
没有版本隔离吧。
试试MultiMC,版本隔离很方便,支持正版登录的。https://multimc.org/
回复

使用道具 举报

黑星星 当前离线
积分
2070
帖子
主题
精华
贡献
爱心
钻石
人气
下界之星
最后登录
1970-1-1
注册时间
2013-11-17
查看详细资料
发表于 2021-8-23 07:21:02 | 显示全部楼层
肯定要用hmcl这类型的启动器,可以做到版本隔离的
回复

使用道具 举报

zhangrere128 当前离线
积分
1058
帖子
主题
精华
贡献
爱心
钻石
人气
下界之星
最后登录
1970-1-1
注册时间
2020-8-24
查看详细资料
发表于 2021-8-23 10:15:53 | 显示全部楼层
黑星星 发表于 2021-8-23 07:21
肯定要用hmcl这类型的启动器,可以做到版本隔离的

原版要进行游戏隔离:
1.进入每个配置的编辑菜单
2.选择游戏目录(通常大家是设置到.Minecraft/versions/对应的版本,如:1.16.4版本选择游戏目录为:.Minecraft/versions/1.16.4
3.所有更改好的配置都重新进入一次
回复

使用道具 举报

zhangrere128 当前离线
积分
1058
帖子
主题
精华
贡献
爱心
钻石
人气
下界之星
最后登录
1970-1-1
注册时间
2020-8-24
查看详细资料
发表于 2021-8-23 10:31:19 | 显示全部楼层
楼主,请你参考5#的做法
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册(register)

本版积分规则

Archiver|小黑屋|Mcbbs.net ( 京ICP备15023768号-1 ) | 京公网安备 11010502037624号 | 手机版

GMT+8, 2021-11-29 01:54 , Processed in 0.064628 second(s), Total 19, Slave 17 queries, Release: Build.2021.11.26 1022, Gzip On, Redis On.

"Minecraft"以及"我的世界"为Mojang Synergies AB的商标 本站与Mojang以及微软公司没有从属关系

© 2010-2020 我的世界中文论坛 版权所有 本站原创图文内容版权属于原创作者,未经许可不得转载

快速回复 返回顶部 返回列表